Freitag, 27. Januar 2023 13:00

Die Tankkontrolle

Eine optische Gedächtnisstütze

Da ich mich schon seit Ewigkeiten darüber geärgert habe daß mein Auto keine Kontrolleuchte hat, die aufleuchtet wenn die Tanknadel langsam (eigentlich wie immer) in den Reserve-Bereich pendelt, muss Abhilfe her!
Vorallendingen, da ich letztens wieder im Tran (mein Hirn stand zwecks Kaffee-Mangel noch auf Stand-By) doch mal testen mußte, ob der Inhalt meines Reservekanisters noch gut ist... und das morgens im Berufsverkehr auf dem Weg zur Arbeit *grummel*
Also mal überlegt wie so eine Tankanzeige arbeitet:

Im Tank befindet sich ein Schwimmer an dem ein Kontakt über einen Widerstandsdraht gleitet. Eigentlich so eine Art Riesenpoti.

Also muss folglich mein Reservebereich einen gewissen Spannungswert darstellen.
Gut, ein Komparator aufgebaut mit einem OP soll herhalten.
Eine Glühbirne, wie sie in den anderen Kontrollen ist, kann ich damit nicht direkt treiben, aber für eine LED reicht es allemal. Rein theoretisch könnte man auch über einen Transistor eine Glühbirne ansteuern... aber eine passende habe ich eh nicht in meinem Fundus, und die Schaltung würde unnötig aufgebläht. Eine gelbe LED soll dafür herhalten, denn das Warnlämpchen am Auto ist generell gelb.

Also flux eine kleine Schaltung zusammengezimmert:

 


Der Aufbau ist standesgemäß auf Streifenraster mit Drahtverhau.

Schaltplan:

Es handelt sich um eine simple Komparator-Schaltung mit einem LM258 OP.
Er vergleicht das Signal des Tankgebers mit einer Referenzspannung, die sich mittels eines Trimmers stufenlos einstellen lässt. Am Ausgang hängt eine gelbe LED mit passendem Vorwiderstand. Vorteil ist, daß es mir egal sein kann, ob das Ausgangssignal des Tankgebers linear oder sonstwas ist. Eingeeicht auf den Arbeitspunkt (hier Beginn des Reserve-Bereichs) sollte die LED sauber dazugeschaltet werden.
Da liegen aber auch die Nachteile....
Zum Ersten habe ich keine saubere Referenz, denn das Poti kann wohl nicht als solche angesehen werden, da die eingestellte Spannung gewaltig schwanken kann. Aber auf ein paar Liter kommt es mir eh nicht an, da die Tankanzeige sowieso dazu neigt eher die relative Mondfeuchtigkeit als alles Andere anzuzeigen.
Zum Zweiten kann es vorkommen, daß sich die Schaltung auf den Arbeitspunkt einschwingt, da sie null Hysterese hat. Gut, bei anderen Autos glimmt das Ding auch im Übergangsbereich mal vor sich hin.....
Soweit die Theorie, aber kommen wir zur Praxis:

Da es heute Nachmittag ausnahmsweise mal trocken war, mal schnell ins Auto um den Tachoblock auszubauen (dachte ich....). 183 Schrauben und viele Flüche später musste ich feststellen, daß die ersten beiden Schrauben die ich gelöst hatte eigentlich genügt hätten... der Rest der blöden Verkleidung war nur geclipst :-( *arghhhh*

Naja, nun konnte ich die vier Schrauben sehen, die den ganzen Rotz in seiner Position halten... also raus damit!
Darufhin ließ sich der Tachoblock auch genau so weit herausziehen, daß man grade nicht mit den Fingern dahinter kommt *kotz*
Mit viel Gewalt und bösen Worten konnte ich die Tachowelle dann doch runterbekommen, und langsam kamen die ersten Zweifel auf wie ich das jemals da wieder rein bekommen soll... gut, jetzt war es eh zu spät ;)

Also noch den Flachstecker runter, und da war er:


Der Streifen im unteren Bereich beherbergt die Kontrollämpchen, und ganz rechts ist sogar ein Symbol in der Tachofolie für meine gewünschte Kontrolle vorgesehen... Glück gehabt und Arbeit gespart, denn ich hatte mich schon seelisch drauf vorbereitet neben dem Tanksymbol ein 5mm Loch für die LED bohren zu müssen....

So sieht das Ganze dann von hinten aus:


Also mal flink die gelbe LED hinter gehalten, und mit Spannung versehen... das Ergebnis war alles andere als zufriedenstellend... nur in absoluter Dunkelheit konnte man mit viel Phantasie das Symbol glimmen sehen (ist wohl heute nicht mein Tag).
Gut, eine andere LED muss her... das nächste was mir in meiner Grabbelkiste über den Weg lief war eine ultrahelle weiße 10000mcd LED... also nächster Versuch!
Das Ergebnis konnte sich sehen lassen. Das Symbol leuchtete so hell, das man schon Angst bekommen musste, den Tank jemals leer zu fahren. Und wenn man nicht schnell genug eine Tanke gefunden hätte, hätte das bestimmt kurzfristig zu Netzhautablösungen geführt.

Also auch absolut unbrauchbar....

Aber man gibt ja nicht auf... Die weiße 3500mcd LED, die mir als nächstes in die Hände fiel, war so schlecht (viel zu hoher blau Anteil) das es echt grausam aussah... aber die Helligkeit war in Ordnung.

Da waren doch noch irgendwo superhelle farbige LEDs... aber wo?
Nachdem ich sie gefunden hatte, mußte ich mit Entsetzen feststellen, daß die Unterteilung im Sortimentskästchen aufgegeben hatte, und sich alle LEDs gemütlich miteinander vermengt hatten. Da diese LEDs alle ein klares Gehäuse haben, war das nicht ganz so lustig.... 500 LEDs mit ner Knopfzelle ausgetestet später habe ich doch noch eine Orange gefunden. Da ich Null Ahnung habe, wo die mal her war, und es daher mit Datenblättern schlecht aussieht habe ich sie einfach mal mit 2V/20mA geschätzt.

Das Ergebnis sah gut aus:


Dabei ist mir auch zufälligerweise ein passender Reflektor über den Weg gelaufen :-)
Also das soll jetzt da rein:


Reflektor mit einem Stück Pappe und Heißkleber passend gemacht:

Die Anschlüsse ließen sich schnell finden. Da bei sämtlichen Instrumenten zwei Anschlüsse verbunden waren, konnten das nur +12V und Masse sein.... Ein Anschluss lief dann noch auf sämtliche Anschlüsse der Beleuchtung weiter, also war Masse auch geklärt.... mal kurz 12V drauf, und die Tankanzeige wanderte munter Richtung „voll“. Blieb nur noch ein Anschluss an der Tankuhr, nämlich das Signal vom Tankgeber.

Etwas löten und Heißkleber später sah es dann so aus:


Nun kommt die Stunde der Wahrheit... also wieder rein mit dem Krams (uih... das ist ja schon richtig dunkel geworden draussen, aber da muß ich jetzt durch denn ich brauche das Auto morgen früh wieder).

Erschreckenderweise und allen Befürchtungen zum Trotz ging der Einbau verhältnismäßig problemlos... da ich die Schaltung eh noch auf Arbeitspunkt trimmen muss, und ich heute etwas getankt habe damit ich nicht wieder den Reservekanister morgen früh bemühen muss, müssen erstmal die vier Schrauben vom Tachoblock reichen, und die Schaltung baumelt munter raus damit ich sie einstellen kann wenn ich den Tank wieder entsprechend leer gefahren habe....

Also Zündung an... und *würg*... die Tankanzeige schnellt von „voll“ auf „megaleer“ und verharrt dort eisern :-(

Irgendwie scheinen meine Überlegungen über den Tankschwimmer nicht zu stimmen, denn der hohe Eingangswiderstand der Schaltung kann die Anzeige nicht so belasten, daß es nennenswerte Änderungen gegeben hätte....

Da es langsam zu dunkel geworden ist, hab ich erstmal den Draht zum Messanschluss der Tankanzeige gekappt, damit diese wieder normal anzeigt... ansonsten hätte ich morgen ein echt mulmiges Gefühl...

Muss ich mich doch noch mal genauer mit dem Messfühler im Tank und der Anzeige meines Fords beschäftigen....


Am nächsten Tag habe ich den ganzen Rotz dann nochmal wieder ausgebaut. Der Fehler wurde schnell klar als ich gesehen hatte, daß ich beim Einbau ein Kabel meiner Schaltung abgequetscht hatte, und das Ende dann munter auf Masse baumelte. Die Schaltung hat sich also aus dem Signal des Tankgebers versorgt und diesen damit dann zu stark belastet.
Also das Kabel kurzerhand wieder geflickt, und diesmal besser aufgepasst.

Und was soll ich sagen? Die Schaltung funktionierte... Naja, so fast. Einen kleinen Fehler gab es noch. Die Kontrolle leuchtete bei genügend Sprit, und ging dann sauber zur Reserve hin aus ;-)
Also nochmals raus den Krams, und den invertierenden und nichtinvertierenden Anschluß am OP getauscht....

Seit dem verrichtet die Schaltung treue Dienste in meinem Auto.

 

- Projekt abgeschlossen -

 

Publiziert am: Freitag, 27. Juli 2007 (4268 mal gelesen)
Copyright © by Simons Page

Druckbare Version  Diesen Artikel an einen Freund senden

[ Zurück ]

 

2007 by Midnight

Seitenerstellung in 0.0427 Sekunden, mit 14 Datenbank-Abfragen